Manjaro Linux 乐于简单

求助! manjaro无法使用fcitx输入法

论坛 新手初步 求助! manjaro无法使用fcitx输入法

该主题包含 15 个回复,有 5 个参与者,并且由  www11y 于 2 周 6 天 前 最后一次更新。

  • robuts 回复

    现在用手机打的字。这系统连输入法都不给装啊。fcitx已经手动安装好了。但是gnome桌面里右上角愣是无法调出输入法。kde也是一样没法使用已经安装好的fcitx输入法。

  • major 回复

    安装了输入法之后,还要在/etc/profile或~/.xprofile里添加如下内容:

    export GTK_IM_MODULE=fcitx
    export XMODIFIERS=@im=fcitx
    export QT_IM_MODULE=fcitx

    然后注销桌面或重启系统就可以正常使用fcitx输入法了。

    • robuts 回复

      回复的好及时,谢谢。

  • Andrew 回复

    我已经按照上面的配置都做了啊,还是不行。查看fcitx configure配置里有fcitx,sougou等。就是调不出来,为什么?

    • rokee 回复

      me too! cannot typed chinese

      • Andrew 回复

        你用的是什么环境啊,我用的是i3wm,配置文件是/etc/profile 或~/.profile
        现在行了,你网上再搜索下,好像有的再加一行的。
        export GTK_IM_MODULE=fcitx
        export XMODIFIERS=@im=fcitx
        export QT_IM_MODULE=fcitx
        fcitx -d -r  类似这样的,我不知道行不行,反正我不知道是不是加了这个缘故就行了。
        还有看下后台程序fcitx 是否已经运行了。
        ps -e|grep fcitx 看下进程。

  • rokee 回复

    谢谢你的热心回复,我已经解决了,是快捷键设置的冲突问题导致输入法不能激活

    • ironhide 回复

      ni de zhong duan li neng shu ru zhong wen ma?

      • rokee 回复

        可以的,我装了搜狗输入法

      • ironhide 回复

        我也是装的搜狗,但是kconsole里没办法输入中文。。

      • rokee 回复

        我用的gnome,kde我也不知道啊

    • levisonchen 回复

      能不能具体说一下是那些快捷键冲突了, 我也碰上了这个问题没法解决. 谢谢

      • rokee 回复

        就是默认的激活快捷键,ctrl+space,一开始我把它改掉了,激活不了,后来我把它改回来就好了。

      • lance 回复

        五笔无法调出来

      • rokee 回复

        你需要在配置输入法界面点”+”把你要用的输入法添加到已安装,并且不能放在第一个

  • www11y 回复

    在 gnome-terminal中 Ctrl + Space 不能调出输入法
    我复制的,在我虚拟机里边是有用的,可以试一试:
    使用 GDM 3.16 启动 GNOME,可能在某些程序中无法使用 Ctrl + Space 调出输入法。解决方法是修改GSettings配置

    gsettings set \
    org.gnome.settings-daemon.plugins.xsettings overrides \
    “{‘Gtk/IMModule’:<‘fcitx’>}”

回复:求助! manjaro无法使用fcitx输入法
您的信息:


«-必填


«-必填,不公开


«-可以推广您的网站

− 3 = 1